EN SON YAZILAR

Linux Mint ekibi Linux Mint 21.1 "Vera" XFCE Beta sürümünü yayınladı.

Linux Mint 21.1 LTS desteğine sahip olan sürüm 2027'e kadar desteklenecek. Güncellenmiş yazılımları ve yeni özellikleri içerisinde barındıran bu sürüm, kullanımınızı daha rahat hale getiriyor.

Bu yeni sürümde birçok geliştirme mevcut. Bunların neler olduğunu şu adresten öğrenebilirsiniz.

Linux Mint 21.1 "Vera" XFCE Beta Sistem Gereksinimleri:
  • 2GB Ram (Rahat kullanım için 4 GB tavsiye edilir)
  • 20GB Disk alanı (100 GB tavsiye edilir)
  • 1024x768 çözünürlük (Daha az çözünürlükler için ekrana sığmıyorsa, ALT tuşuna basıp pencereyi sürükleyebilirsiniz)
Güncelleme Talimatları:
  • Ayrıca Beta sürümünden Kararlı sürüme ve Linux Mint 21'den yükseltme mümkün olacak.
  • Güncelleme talimatları daha sonra yayınlanacak.  

Linux Mint ekibi Linux Mint 21.1 "Vera" MATE Beta sürümünü yayınladı.

Linux Mint 21.1 LTS desteğine sahip olan sürüm 2027'e kadar desteklenecek. Güncellenmiş yazılımları ve yeni özellikleri içerisinde barındıran bu sürüm, kullanımınızı daha rahat hale getiriyor.

Bu yeni sürümde birçok geliştirme mevcut. Bunların neler olduğunu şu adresten öğrenebilirsiniz.

Linux Mint 21.1 "Vera" MATE Beta Sistem Gereksinimleri:
  • 2GB RAM (Rahat kullanım için 4GB tavsiye edilir)
  • 20GB Disk alanı (100 GB tavsiye edilir)
  • 1024×768 çözünürlük (Daha düşük çözünürlüğe sahip ekranlarda pencere sığmıyorsa ALT tuşuna basarak fareyle pencereyi sürükleyin)
Güncelleme Talimatları:
  • Ayrıca Beta sürümünden Kararlı sürüme ve Linux Mint 21'den yükseltme mümkün olacak.
  • Güncelleme talimatları daha sonra yayınlanacak.  

Linux Mint ekibi Linux Mint 21.1 "Vera" Cinnamon Beta sürümünü yayınladı.

Linux Mint 21.1 LTS desteğine sahip olan sürüm 2027'e kadar desteklenecek. Güncellenmiş yazılımları ve yeni özellikleri içerisinde barındıran bu sürüm, kullanımınızı daha rahat hale getiriyor.

Bu yeni sürümde birçok geliştirme mevcut. Bunların neler olduğunu şu adresten öğrenebilirsiniz.

Linux Mint 21.1 "Vera" Cinnamon Beta Sistem Gereksinimleri:
  • 2GB RAM (Rahat kullanım için 4GB tavsiye edilir)
  • 20GB Disk alanı (100 GB tavsiye edilir)
  • 1024×768 çözünürlük (Daha düşük çözünürlüğe sahip ekranlarda pencere sığmıyorsa ALT tuşuna basarak fareyle pencereyi sürükleyin)
Güncelleme Talimatları:
  • Ayrıca Beta sürümünden Kararlı sürüme ve Linux Mint 21'den yükseltme mümkün olacak.
  • Güncelleme talimatları daha sonra yayınlanacak.  

Polychromatic, OpenRazer çevre birimlerini özelleştirmek için açık kaynaklı bir RGB aydınlatma yönetimi ön uç uygulamasıdır.

Polychromatic ile Razer klavyeleri, fareleri, tuş takımları için aydınlatmayı, RGB efektlerini ve bazı özel işlevleri yönetebilirsiniz. Bu projenin, diğer markaların çevre birimlerini de desteklemek gibi uzun vadeli bir hedefi var.

Polychromatic’in desteklediği cihazların listesine şu adresten ulaşabilirsiniz.

Linux’ta Polychromatic Kurulumu Nasıl Yapılır?

Polychromatic sadece bir ön uçtur. Henüz yapmadıysanız, önce OpenRazer programını yüklemeniz gerekir.

OpenRazer’ı xUbuntu 20.04/Linux Mint 20.x’te kurmak için aşağıdaki 3 komutu terminalde çalıştırın.

echo 'deb http://download.opensuse.org/repositories/hardware:/razer/xUbuntu_20.04/ /' | sudo tee /etc/apt/sources.list.d/hardware:razer.list

curl -fsSL https://download.opensuse.org/repositories/hardware:razer/xUbuntu_20.04/Release.key | gpg --dearmor | sudo tee /etc/apt/trusted.gpg.d/hardware_razer.gpg > /dev/null

sudo apt update && sudo apt install openrazer-meta

OpenRazer’ı xUbuntu 21.10’da kurmak için aşağıdaki 3 komutu terminalde çalıştırın.

echo 'deb http://download.opensuse.org/repositories/hardware:/razer/xUbuntu_21.10/ /' | sudo tee /etc/apt/sources.list.d/hardware:razer.list

curl -fsSL https://download.opensuse.org/repositories/hardware:razer/xUbuntu_21.10/Release.key | gpg --dearmor | sudo tee /etc/apt/trusted.gpg.d/hardware_razer.gpg > /dev/null

sudo apt update && sudo apt install openrazer-meta

OpenRazer’ı DEB dosyası olarak indirip kurmak isterseniz aşağıdaki indirme bağlantılarını kullanabilirsiniz.


Not: Ubuntu ve Linux Mint dışındaki dağıtımlardan birini kullanıyorsanız, OpenRazer’ı kurmak için şu sayfaya bakabilirsiniz. 

Polychromatic’i kurabileceğiniz Ubuntu ve türevleri dağıtımlar:
  • Ubuntu 18.04 veya üstü
  • Linux Mint 19 veya üstü
  • elementaryOS 0.4 veya üstü
  • KDE Neon
  • Pop!_OS 20.04 veya üstü
  • Zorin OS 11 veya üstü
Polychromatic’i kurmak için aşağıdaki 2 komutu terminalde çalıştırın.

sudo add-apt-repository ppa:polychromatic/stable
sudo apt update && sudo apt install polychromatic

Yukarıdaki komuta ek olarak bileşenleri seçerek yüklemek isterseniz aşağıdaki komutu kullanabilirsiniz.

sudo apt install polychromatic-controller polychromatic-tray-applet polychromatic-cli

Polychromatic’i Arch Linux’ta kurmak istiyorsanız aşağıdaki komutu terminalde çalıştırın.

yay -S polychromatic

Polychromatic’i Fedora’da kurmak istiyorsanız aşağıdaki 2 komutu terminalde çalıştırın.

sudo dnf config-manager --add-repo https://download.opensuse.org/repositories/hardware:razer/Fedora_37/hardware:razer.repo

sudo dnf install polychromatic

ClamAV, Genel Kamu Lisansı ile lisanslanmış çoklu platform destekli bir antivirüs yazılımıdır. Otomatik virüs veritabanı güncelleme özelliğine sahiptir. Daha çok Unix temelli sistemler için tasarlanmaya başlanmış olmakla birlikte Windows, Mac OS X ortamlarında da kullanılabilmektedir.

ClamAV, e-posta ve web taraması ve uç nokta güvenliği dahil olmak üzere çeşitli durumlarda kullanılan, truva atlarını, virüsleri, kötü amaçlı yazılımları ve diğer kötü amaçlı tehditleri tespit etmeye yönelik açık kaynaklı bir anti-virüs motorudur.

ClamTk, Linux masaüstü kullanıcıları için ClamAV komut satırı antivirüs yazılım programı için ücretsiz bir yazılım grafik arayüzüdür. Hem isteğe bağlı hem de zamanlanmış tarama sağlar. Proje Dave Mauroni tarafından Şubat 2004'te başlatıldı ve geliştirilmesi hala devam etmektedir.

ClamAV’ın Özellikleri:

  • Komut satırı tarayıcısı.
  • Sendmail için Milter arayüzü.
  • Komut dosyası güncellemelerini ve dijital imzaları destekleyen gelişmiş veritabanı güncelleyici.
  • Günde birden çok kez güncellenen virüs veritabanı.
  • Tüm standart posta dosyası biçimleri için yerleşik destek.
  • ZIP, RAR, Dmg, Tar, GZIP, BZIP2, OLE2, Kabine, CHM, BinHex, SIS ve diğerleri dahil olmak üzere çeşitli arşiv biçimleri için yerleşik destek.
  • UPX, FSG, Petite, NsPack, wwpack32, MEW, Upack ile paketlenmiş ve SUE, Y0da Cryptor ve diğerleriyle gizlenmiş ELF yürütülebilir dosyaları ve Taşınabilir Çalıştırılabilir dosyalar için yerleşik destek.
  • MS Office ve MacOffice dosyaları, HTML, Flash, RTF ve PDF gibi popüler belge biçimleri için yerleşik destek. 

Linux’te ClamAV Kurulumu Nasıl Yapılır?

ClamAV’ı kurmak için dilerseniz şu sayfadan en güncel LTS sürümünü indirebilir ya da aşağıdaki indirme bağlantılarını kullanabilirsiniz. 

ClamAV – 32Bit (DEB) ClamAV – 64Bit (DEB) ClamAV – 32Bit (RPM) ClamAV – 64Bit (RPM)

Linux’te ClamTk Kurulumu Nasıl Yapılır?

ClamTk’yı kurmak istediğiniz sistem RPM’i destekliyorsa aşağıdaki komutlardan birini terminalde çalıştırabilirsiniz.

sudo yum install clamtk
sudo dnf install clamtk

ClamTk’yı kaldırmak isterseniz aşağıdaki komutlardan birini kullanabilirsiniz.

sudo yum erase clamtk
sudo dnf erase clamtk

ClamTk’yı kurmak istediğiniz sistem DEB’i destekliyorsa aşağıdaki komutu terminalde çalıştırabilirsiniz.

sudo apt install clamtk

ClamTk’yı kaldırmak isterseniz aşağıdaki komutu kullanabilirsiniz.

sudo dpkg --purge clamtk

Python 3.11 sürümünün, bir önceki Python 3.10 sürümünden %10-60 oranında daha hızlı olduğu iddia ediliyor. Bu yazıda sizlere Python’ın en son sürümü olan 3.11 sürümünün nasıl kurulacağından bahsedeceğim.

Python 3.11’deki yenilikleri öğrenmek isterseniz şu sayfadan öğrenebilirsiniz.

Linux’te Python 3.11 Nasıl Kurulur?

Python 3.11’i kurmak için aşağıdaki komutları terminalde çalıştırın.

sudo add-apt-repository ppa:deadsnakes/ppa
sudo apt update && sudo apt install python3.11

Not: Dilerseniz pip paket yöneticisi, IDE kurulumu vs için yukarıdaki python3.11’i python3.11-full olarak değiştirebilirsiniz.

Kurulumu yaptıktan sonra Python’ın sürümünü kontrol etmek için aşağıdaki 2 komuttan birini kullanabilirsiniz.

python3.11 --version
python3.11 -m pip --version

Not: Ubuntu'daki varsayılan Python3'ü değiştirmek, GNOME Terminali gibi bazı varsayılan uygulamalar için sorunlara neden olabilir.

Python 3.11’i varsayılan python3 olarak ayarlamak için aşağıdaki komutları çalıştırın.

sudo update-alternatives --install /usr/bin/python3 python3 /usr/bin/python3.10 110
sudo update-alternatives --install /usr/bin/python3 python3 /usr/bin/python3.11 100

Python3 sürümleri arasında geçiş yapmak isterseniz aşağıdaki komutu kullanabilirsiniz.

sudo update-alternatives --config python3

Python 3.11’i kaldırmak için aşağıdaki komutları kullanabilirsiniz.

sudo apt install ppa-purge && sudo ppa-purge ppa:deadsnakes/ppa
sudo apt remove --autoremove python3.11 python3.11-minimal

Polat Büyükarslan

İletişim Formu

Ad

E-posta *

Mesaj *

Blogger tarafından desteklenmektedir.